Fix HMI framework recipes
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-multimedia / agl-service-soundmanager-2017 / agl-service-soundmanager-2017_git.bb
1 SUMMARY     = "Sound Manager binding and client library for application"
2 ESCRIPTION = "Sound Manager is the binding library to communicate \
3         with Genivi Audio Manager. Genivi Audio Manager is the policy manager \
4         about sound. It controls volume and routing according to various situations.\
5         This recipe also provides client library to communicate with sound manager. \
6         "
7 HOMEPAGE    = "https://wiki.automotivelinux.org/soundmanager"
8 S = "${WORKDIR}/git"
9 SECTION = "multimedia"
10 LICENSE     = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
12 DEPENDS = "dbus glib-2.0 af-binder json-c"
13 RDEPENDS_${PN} = "audiomanager audiomanager-plugins"
14
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager-2017;protocol=https;branch=master"
16 SRCREV = "2ad2d4f0879d091debf3853cfac0cd5129d5699a"
17
18 inherit cmake aglwgt
19
20 do_install_append() {
21         install -d ${D}${sysconfdir}/dbus-1/system.d
22         install -m 0644 ${S}/conf/soundmanager-dbus.conf ${D}${sysconfdir}/dbus-1/system.d/
23         install -d ${D}${libdir}/pkgconfig
24         install -m 0644 ${B}/soundmanager.pc ${D}${libdir}/pkgconfig
25         install -d ${D}${includedir}
26         install -m 0644 ${S}/include/libsoundmanager.hpp ${D}${includedir}
27
28         install -m -0755 ${B}/libsoundmanager/libsoundmanager.so ${D}${libdir}/libsoundmanager.so.0.1
29         ln -sf libsoundmanager.so.0.1 ${D}${libdir}/libsoundmanager.so
30 }
31
32 FILES_${PN} += "${sysconfdir}/dbus-1/system.d/soundmanager-dbus.conf"