d406d20826ea619caf275d69a6a06311ebf1fe7b
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-graphics / agl-service-windowmanager-2017 / agl-service-windowmanager-2017_git.bb
1 SUMMARY     = "Window Manager binding and client library for application"
2 DESCRIPTION = "Window Manager 2017 is the binding library  \
3         "
4 HOMEPAGE    = ""
5 S = "${WORKDIR}/git"
6 SECTION = "graphics"
7 LICENSE     = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
9 DEPENDS = "af-binder json-c wayland wayland-ivi-extension"
10 RDEPENDS_${PN} = " \
11         "
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
14 SRCREV = "797eac5c26337df9d444e0a5e396be93454249dd"
15
16 inherit cmake aglwgt
17
18 #If you would like to output log, uncomment out
19 #EXTRA_OECMAKE = " -DENABLE_DEBUG_OUTPUT=ON "
20
21 do_install_append() {
22     install -d ${D}${sysconfdir}/windowmanager
23     install -m 0644 ${S}/layers.json ${D}${sysconfdir}/windowmanager/
24     install -d ${D}${libdir}/pkgconfig
25     install -m 0644 ${B}/windowmanager.pc ${D}${libdir}/pkgconfig
26     install -d ${D}${includedir}
27     install -m 0644 ${S}/libwindowmanager/libwindowmanager.h ${D}${includedir}
28
29     install -m -0755 ${B}/libwindowmanager/libwindowmanager.so ${D}${libdir}/libwindowmanager.so.0.1
30     ln -sf libwindowmanager.so.0.1 ${D}${libdir}/libwindowmanager.so
31 }
32 FILES_${PN} += "${sysconfdir}/windowmanager/layers.json"