Merge "Bump agl-service-windowmanager revision"
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-graphics / agl-service-windowmanager / agl-service-windowmanager_git.bb
1 SUMMARY     = "Window Manager service binding for applications"
2 DESCRIPTION = "Window Manager is the service binding for controlling \
3                rendering rights. Applications request to render itself, \
4                then Window Manager checks the policy and notifies the \
5                layout to the respective applications \
6               "
7 HOMEPAGE    = "https://wiki.automotivelinux.org/windowmanager"
8 SECTION     = "graphics"
9 LICENSE     = "Apache-2.0"
10 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93 \
11                     file://LICENSE.MIT;md5=a7514fe5664902e337bd8a4443d8f348"
12
13 DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
14
15 inherit cmake aglwgt
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH}"
18 SRCREV = "9fabd6550e183283363b61f71092477342a357d1"
19 PV = "1.0+git${SRCPV}"
20 S = "${WORKDIR}/git"
21
22 #If you would like to output log, uncomment out
23 EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "