Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-demo-hmi / homescreen-2017 / homescreen-2017_git.bb
1 SUMMARY     = "AGL Home Screen 2017 Application"
2 DESCRIPTION = "AGL Home Screen 2017 Application build with recipe method"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/gitweb?p=staging/homescreen-2017.git"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = "\
9         qtbase \
10         qtdeclarative \
11         qtquickcontrols2 \
12         pulseaudio \
13         agl-service-homescreen-2017 \
14         agl-service-windowmanager-2017 \
15         libhomescreen \
16         libwindowmanager \
17 "
18
19 inherit qmake5 systemd pkgconfig aglwgt
20
21 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/homescreen-2017;protocol=https;branch=${AGL_BRANCH}"
22 SRCREV  = "4940d001f08bec6fd68293efcbd6673a9ffce65e"
23 S       = "${WORKDIR}/git/"
24
25 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"