96e9cc9276920b7b017d04f2325d873e6ba0789e
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / 4a-hal-unicens / 4a-hal-unicens_git.bb
1 SUMMARY     = "4A - Unicens (MOST) Binding"
2 DESCRIPTION = "Unicens binding (MOST audio network support) for 4A (AGL Advanced Audio Agent)"
3 HOMEPAGE    = "https://github.com/tjahnk/4a-hal-unicens"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=dab9a7a261563ca5dafa097c91369074"
8
9 DEPENDS += "lua"
10
11 SRC_URI = "gitsm://github.com/tjahnk/4a-hal-unicens;protocol=https;branch=${AGL_BRANCH}"
12 SRCREV = "8be9b941f6364ba8f251ef6acb95350a8e289ce3"
13
14
15 PV = "0.1+git${SRCPV}"
16 S  = "${WORKDIR}/git"
17
18 inherit afb-system-cmake
19
20 do_install_append () {
21     # installation folder for this plugin is '4a-hal'
22     # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
23     PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
24
25     # transition: provided by separate package
26     rm -rf $PKGDIR/etc
27 }
28
29