4a-mixer: remove useless dependency on pulseaudio
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / meta-agl-demo / recipes-multimedia / 4a-mixer / 4a-mixer_git.bb
1 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV  = "3c8498d95c3f89def2eb49b668fa70cd12faace7"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "qtquickcontrols2 \
17             qtwebsockets \
18             virtual/libhomescreen \
19             qlibwindowmanager \
20 "
21
22 PROVIDES += "virtual/mixer"
23 RPROVIDES_${PN} += "virtual/mixer"
24
25 inherit cmake_qt5 aglwgt