tests: Add two Chromiums tests to packagegroup-ivi-common-test.bb
[AGL/meta-agl.git] / meta-app-framework / recipes-support / libzip / libzip_1.1.1.bb
1 inherit autotools
2
3 SUMMARY = "Library providing support for handling zip files"
4 DESCRIPTION = "\
5  This library is wrapping zlib and allows \
6  to easily create, browse, inflate of deflate \
7  the zip files. \
8  It also provides tools for zip comparing, merging or browsing.\
9 "
10
11 HOMEPAGE = "http://nih.at/libzip/index.html"
12 LICENSE = "BSD"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=23ebf7ca347ed9703b4ef40824d0ef66"
14
15 SRC_URI = "http://nih.at/libzip/libzip-1.1.1.tar.xz;md5sum=0c86a1a94fbc3ec6724801036726ae1f"
16
17 #SRC_URI = "hg://hg.nih.at/libzip;module=libzip;protocol=http"
18 #SRCREV = "5895e34af7f9"
19 #S = "${HGDIR}"
20
21 SECTION = "base"
22
23 DEPENDS = "zlib"
24
25 RDEPENDS_${PN} = "zlib"
26
27 PROVIDES += "${PN}-tools"
28 RDEPENDS_${PN}-tools = "${PN}"
29 FILES_${PN}-tools = "${bindir}/zipcmp ${bindir}/zipmerge ${bindir}/ziptool"
30
31 BBCLASSEXTEND = "native nativesdk"
32