poky-agl: conf: change to gplv2 version of gdbm
[AGL/meta-agl.git] / meta-app-framework / recipes-support / libmicrohttpd / libmicrohttpd_0.9.55.bb
1 DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2 HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3 LICENSE = "LGPL-2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5 SECTION = "net"
6 DEPENDS = "libgcrypt gnutls file"
7
8 SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9 SRC_URI[md5sum] = "1c20f84a8b9cf692dd50b558b3571a3a"
10 SRC_URI[sha256sum] = "0c1cab8dc9f2588bd3076a28f77a7f8de9560cbf2d80e53f9a8696ada80ed0f8"
11
12 inherit autotools lib_package pkgconfig gettext
13
14 EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
15
16 PACKAGECONFIG ?= "curl"
17 PACKAGECONFIG_append_class-target = "\
18         ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
19 "
20 PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
21 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
22
23 do_compile_append() {
24     sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25 }