libmicrohttpd: upgrade to 0.9.54
[AGL/meta-agl.git] / meta-app-framework / recipes-support / libmicrohttpd / libmicrohttpd_0.9.54.bb
1 DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2 HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3 LICENSE = "LGPL-2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5 SECTION = "net"
6 DEPENDS = "libgcrypt gnutls file"
7
8 SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9 SRC_URI[md5sum] = "9ed8171c7ee8cedce86959635c1db3ae"
10 SRC_URI[sha256sum] = "bcc721895d4a114b0548a39d2241c35caacb9e2e072d40e11b55c60e3d5ddcbe"
11
12 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
13 SRC_URI += " file://Check-response-existence-on-upgrade.patch"
14
15 inherit autotools lib_package pkgconfig gettext
16
17 EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
18
19 PACKAGECONFIG ?= "curl"
20 PACKAGECONFIG_append_class-target = "\
21         ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
22 "
23 PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
24 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
25
26 do_compile_append() {
27     sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
28 }