Merge "Merge: migrate appfw from meta-agl-extra"
[AGL/meta-agl.git] / meta-app-framework / recipes-support / libmicrohttpd / libmicrohttpd_0.9.49.bb
1 DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2 HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3 LICENSE = "LGPL-2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5 SECTION = "net"
6 DEPENDS = "libgcrypt gnutls file"
7
8 SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9 SRC_URI[md5sum] = "3209aa2ac6199b874a6325342b86edbc"
10 SRC_URI[sha256sum] = "9407d8252548ab97ace3276e0032f073820073c0599d43baff832902a8dab11c"
11
12 inherit autotools lib_package pkgconfig
13
14 EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
15
16 PACKAGECONFIG ?= "curl"
17 PACKAGECONFIG_append_class-target = "\
18         ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
19 "
20 PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
21 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
22
23 do_compile_append() {
24     sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25 }