add layer meta-app-framework
[AGL/meta-agl.git] / meta-app-framework / recipes-support / libmicrohttpd / libmicrohttpd_0.9.48.bb
1 DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2 HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3 LICENSE = "LGPL-2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5 SECTION = "net"
6 DEPENDS = "libgcrypt gnutls file"
7
8 SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9 SRC_URI[md5sum] = "9c298c890088a91fe0d7ac3fec9d0097"
10 SRC_URI[sha256sum] = "87667e158f2bf8c691a002e256ffe30885d4121a9ee4143af0320c47cdf8a2a4"
11
12 inherit autotools lib_package
13
14 # disable spdy, because it depends on openssl
15 EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
16
17 PACKAGECONFIG ?= "curl"
18 PACKAGECONFIG_append_class-target = "\
19         ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
20 "
21 PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
22 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
23
24 do_compile_append() {
25         sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
26 }
27