Convert to new override syntax
[AGL/meta-agl.git] / meta-app-framework / recipes-devtools / libappcontroller / libappcontroller_git.bb
1 SUMMARY = "Controller library for an Application Framework"
2 DESCRIPTION = "Controller library to be used to easily create a binding for AGL App Framework"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libappcontroller;protocol=https;branch=${AGL_BRANCH}"
8 SRCREV = "1bef31c8bbad27f4914484c5007b2e199fb073d4"
9
10 PV = "${AGLVERSION}"
11 S  = "${WORKDIR}/git"
12
13 DEPENDS:append = " af-binder libafb-helpers lua"
14 RDEPENDS:${PN}:append = " af-binder lua"
15
16 inherit cmake
17
18 ALLOW_EMPTY:${PN} = "1"
19