meta-agl: split wireplumber to run in multiple instances
[AGL/meta-agl.git] / meta-app-framework / recipes-devtools / cmake-apps-module / cmake-apps-module_git.bb
1 SUMMARY = "CMake module to ease development of apps"
2 DESCRIPTION = "This is a migration of former app-templates git submodule which let you \
3 ease the development of apps and widget building."
4 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/cmake-apps-module"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7 SECTION = "apps"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV = "7c03348d9c2de43684fa69c3c9e227b25daceaaa"
11
12 PV = "${AGLVERSION}"
13 S  = "${WORKDIR}/git"
14
15 inherit cmake
16
17 FILES:${PN} += " ${datadir}/*/Modules/CMakeAfbTemplates*"
18
19 BBCLASSEXTEND = "native nativesdk"
20