web-runtime: add missing runtime dependencies
[AGL/meta-agl.git] / meta-app-framework / recipes-core / web-runtime / web-runtime_0.1.bb
1 inherit allarch
2
3 SUMMARY = "Provides the 'web-runtime' command"
4 DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9 SRC_URI = "\
10         file://web-runtime;md5sum=6114c0bdd20290912a423fa01beb50f0 \
11         file://web-runtime.qml;md5sum=5d6a379e9b7e5654319e5ba638824a58 \
12         file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
13 "
14
15 RDEPENDS_${PN} = "\
16   qtdeclarative-tools \
17   qtwebkit-qmlplugins \
18   qtwayland-qmlplugins \
19   qtquickcontrols-qmlplugins \
20 "
21
22 PROVIDES += "virtual/webruntime"
23 # add also RPROVIDES to satisfy the packagegroup
24 RPROVIDES_${PN} += "virtual/webruntime"
25
26 do_configure() {
27     :
28 }
29
30 do_install() {
31     install -d ${D}${bindir}
32     install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
33     install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
34     install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
35 }
36
37 do_install_append_rcar-gen2() {
38         # workaround for porter board: force the use of libEGL provided by mesa at runtime
39         # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
40     sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
41 }
42
43