Remove patch in newer ti-staging kernel
[AGL/meta-agl.git] / meta-app-framework / recipes-core / systemd / systemd_%.bbappend
1 ##################################################################################
2 # This patch is temporary.
3 # This is a solution to the Bug-AGL SPEC-539.
4 #
5 # It renames the file udev-smack-default.rules
6 # as the file 55-smack-default.rules before installation in do_install.
7 # This comes from https://github.com/01org/meta-intel-iot-security.git
8 # (meta-security-smack/recipes-core/systemd/)
9 # It should be removed when the security layer will be refited to meta-security
10 # See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security
11 #
12 # It also renames the file touchscreen.rules as the file 55-touchscreen.rules
13 # This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
14 # It should be removed when poky changes.
15 ##################################################################################
16 do_install_prepend() {
17         mv ${WORKDIR}/udev-smack-default.rules ${WORKDIR}/55-smack-default.rules || true
18         mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
19 }
20