applaunchd: update and install agl-app@ template and sandboxing configs
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
1 SUMMARY     = "AGL Application Launcher service"
2 DESCRIPTION = "AGL Application Launcher service build with recipe method"
3 HOMEPAGE    = "https://git.automotivelinux.org/src/applaunchd"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     glib-2.0 \
10     glib-2.0-native \
11     systemd \
12 "
13
14 PV = "2.0+git${SRCPV}"
15
16 SRC_URI = " \
17     git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
18     file://agl-app@.service \
19     file://no-network.conf \
20     file://private-tmp.conf \
21 "
22 SRCREV = "efbd734aca8b813710d7564d79696b1cf150a88c"
23
24 S = "${WORKDIR}/git"
25
26 inherit meson pkgconfig
27
28 do_install:append() {
29     # Install generic template for all agl-app services
30     mkdir -p ${D}${sysconfdir}/systemd/system/
31     install -m 644 ${WORKDIR}/agl-app@.service ${D}${sysconfdir}/systemd/system/
32
33     # Install individual sandboxing overrides/drop-ins to be used by apps
34     mkdir -p ${D}${sysconfdir}/systemd/sandboxing/
35     install -m 644 ${WORKDIR}/no-network.conf ${D}${sysconfdir}/systemd/sandboxing/
36     install -m 644 ${WORKDIR}/private-tmp.conf ${D}${sysconfdir}/systemd/sandboxing/
37 }
38
39 FILES:${PN} += " ${datadir}/dbus-1/"
40
41 RDEPENDS:${PN} += " \
42     agl-session \
43     polkit-rule-agl-app \
44 "