meta-app-framework: Update app template scheme
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
1 SUMMARY     = "AGL Application Launcher service"
2 DESCRIPTION = "AGL Application Launcher service build with recipe method"
3 HOMEPAGE    = "https://git.automotivelinux.org/src/applaunchd"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     glib-2.0 \
10     glib-2.0-native \
11     systemd \
12 "
13
14 PV = "2.0+git${SRCPV}"
15
16 SRC_URI = " \
17     git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
18     file://agl-app@.service \
19     file://agl-app-web@.service \
20     file://no-network.conf \
21     file://private-tmp.conf \
22 "
23 SRCREV = "c675bafdf15cc19276bd8276c34f56404a5ecb62"
24
25 S = "${WORKDIR}/git"
26
27 inherit meson pkgconfig
28
29 do_install:append() {
30     # Install generic template for all agl-app services
31     install -d ${D}${systemd_system_unitdir}
32     install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
33     install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
34
35     # Install individual sandboxing overrides/drop-ins to be used by apps
36     install -d ${D}${systemd_system_unitdir}/sandboxing
37     install -m 644 ${WORKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
38     install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
39 }
40
41 PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web"
42
43 FILES:${PN} += "${systemd_system_unitdir} ${datadir}/dbus-1/"
44
45 FILES:${PN}-template-agl-app = "${systemd_system_unitdir}/agl-app@.service"
46
47 FILES:${PN}-template-agl-app-web = "${systemd_system_unitdir}/agl-app-web@.service"
48
49 RDEPENDS:${PN} += " \
50     agl-session \
51     polkit-rule-agl-app \
52 "
53
54 RDEPENDS:${PN}-template-agl-app = "${PN}"
55
56 RDEPENDS:${PN}-template-agl-app-web = "${PN}"