Move genskel to af-binder-tools recipes
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder-devtools_1.0.bb
1 SUMMARY = "App Framework Host Utilities (generators, parsers)"
2 DESCRIPTION = "The AGL App Framework Host Utilities are used to compile applications"
3 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-host-utilities"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 DEPENDS = "json-c"
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-host-utilities;protocol=https;branch=${AGL_BRANCH}"
11
12 SRCREV = "${AGL_DEFAULT_REVISION}"
13 PV = "${AGL_BRANCH}+git${SRCPV}"
14
15 S = "${WORKDIR}/git"
16
17 inherit cmake pkgconfig
18
19 BBCLASSEXTEND += "native nativesdk"