App-FW: Update namings and bug fixes
[AGL/meta-agl.git] / meta-app-framework / recipes-config / agl-users / agl-users_0.1.bb
1 inherit allarch useradd
2
3 SUMMARY = "AGL Users Seed"
4 DESCRIPTION = "This is a core framework component that\
5  defines how users are managed and who are the default users."
6
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10 ALLOW_EMPTY_${PN} = "1"
11
12 USERADD_PACKAGES = "${PN}"
13
14 GROUPADD_PARAM_${PN} = " --system display ; --system weston-launch"
15
16 USERADD_PARAM_${PN} = "\
17   -g users -G display -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
18   -g users -G display -d /home/agl-passenger -m -K PASS_MAX_DAYS=-1 agl-passenger ; \
19   --gid display --groups weston-launch,video,input --home-dir /run/platform/display --shell /bin/false --comment \"Display daemon\" --key PASS_MAX_DAYS=-1 display \
20 "