Add aglwgt class
[AGL/meta-agl.git] / meta-app-framework / classes / aglwgt.bbclass
1 #
2 # aglwgt bbclass
3 #
4 # Jan-Simon Moeller, jsmoeller@linuxfoundation.org
5 #
6 # This class expects a "make package" target in the makefile
7 # which creates the wgt files in the package/ subfolder.
8 # The makefile needs to use wgtpkg-pack.
9 #
10
11
12 # 'wgtpkg-pack' in af-main-native is required.
13 DEPENDS_append = " af-main-native"
14
15 # for bindings  af-binder is required.
16 DEPENDS_append = " af-binder"
17
18 do_aglwgt_package()  {
19         cd ${B}
20         make package || ( \
21           bbwarn "Your makefile must support the 'make package' target" ; \
22           bbwarn "and generate a .wgt file using wgtpack in the"; \
23           bbwarn "subfolder ./package/ !" ; \
24           bbwarn "Fix your package as it will not work within the SDK" ; \
25           bbwarn "See: https://wiki.automotivelinux.org/troubleshooting/app-recipes" \
26                         )
27 }
28
29 do_aglwgt_deploy() {
30         install -d ${D}/usr/AGL/apps
31         install -m 0644 ${B}/package/*.wgt ${D}/usr/AGL/apps/
32 }
33
34 FILES_${PN} += " /usr/AGL/apps/*.wgt "
35
36 addtask aglwgt_package before do_build after do_compile
37 addtask aglwgt_deploy  before do_build after do_install