7b470ef01a913a398395ebe578bd8fb89b0ce75b
[AGL/meta-agl-devel.git] / meta-agl-wireless-monitor / recipes-component / libcgic / libcgic_2.0.8.bb
1 SUMMARY = "CGIC library"
2 HOMEPAGE = "https://github.com/boutell/cgic"
3 DESCRIPTION = "An ANSI C library for CGI Programming."
4
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://license.txt;md5=1ef0cf0c9e6e61f326fd48746179cf38"
7
8 SRCREV = "a3490b7612f194f029b6e7a7fc602ad962bc33e2"
9
10 S = "${WORKDIR}/git"
11
12 SRC_URI = "git://github.com/boutell/cgic.git;protocol=https;branch=master \
13            file://0001-modify-makefile-for-cross-build.patch \
14 "
15
16 EXTRA_OEMAKE = "LDFLAGS='${LDFLAGS}'"
17
18 do_install() {
19     install -d ${D}/usr/bin/cgi-bin
20     install -m 0755 ${S}/capture ${D}/usr/bin/cgi-bin
21     install -m 0755 ${S}/cgictest.cgi ${D}/usr/bin/cgi-bin
22 }