agl-test-framework: add three build modes
[AGL/meta-agl-devel.git] / meta-agl-test / recipes-tests / aio-stress / aio-stress_0.22.bb
1 SUMMARY = "Aio Stress Test"
2 HOMEPAGE = "https://oss.oracle.com/~mason/aio-stress/"
3 LICENSE = "GPL-2.0-only"
4 SRC_URI[sha256sum] = "3f4cffcc946fb717fff9d8fe932c7c2ee606efff198408d9fbe16955151445f7"
5 LIC_FILES_CHKSUM = "file://aio-stress.c;md5=ccb5d196a3736bbd835d582a4e2329c3"
6
7 PN = 'aio-stress'
8
9 DEPENDS = "libaio"
10
11 TARGET_CC_ARCH += "${LDFLAGS}"
12
13 SRC_URI = "https://oss.oracle.com/~mason/aio-stress/aio-stress.c \
14            file://Makefile "
15
16 S = "${WORKDIR}"
17
18 FILES:${PN} += " \
19     /usr/AGL/agl-test/tests/aio_stress/resource \
20 "
21
22 do_compile() {
23     oe_runmake
24 }
25
26 do_install:append() {
27     install -d ${D}/usr/AGL/agl-test/tests/aio_stress/resource/
28     install -m 0755 ${WORKDIR}/aio-stress ${D}/usr/AGL/agl-test/tests/aio_stress/resource/
29 }