Add WLAN card support
[AGL/meta-agl-refhw.git] / meta-agl-refhw-gen3 / recipes-bsp / ti-bt-firmware / ti-bt-firmware_git.bb
1 SUMMARY = "Bluetooth firmare files for WL18xx combo modules"
2 LICENSE = "TI-TFL"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=f39eac9f4573be5b012e8313831e72a9"
4
5 # Use the commit ID for PV since several different firmware versions
6 # are mixed together.
7 PV = "git${SRCPV}"
8
9 SRC_URI = "git://git.ti.com/ti-bt/service-packs.git;branch=master"
10 SRCREV = "6c9104f0fb7ca1bfb663c61e9ea599b3eafbee67"
11
12 S = "${WORKDIR}/git"
13
14 inherit allarch
15
16 CLEANBROKEN = "1"
17
18 do_compile[noexec] = "1"
19 do_configure[noexec] = "1"
20
21 do_install() {
22     install -d  ${D}${nonarch_base_libdir}/firmware/ti-connectivity/
23     oe_runmake "DEST_DIR=${D}" "BASE_LIB_DIR=${nonarch_base_libdir}" install
24 }
25
26 FILES_${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"