Initial check-in
[AGL/meta-agl-refhw.git] / meta-agl-refhw-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_%.bbappend
1 #FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
2
3 # There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
4 # u-boot have to be stored into eMMC by using serial donwload.
5 EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
6
7 DDR_8G_OPTION= "RCAR_DRAM_LPDDR4_MEMCONF=1"
8
9 ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} "
10
11 # In arm-trusted-firmware-control.inc, a "extra_ipl_opt" task is appended to
12 # create firmware for 4x2g or 2x2g variation. it is supposed to use
13 # EXTRA_ATFW_OPT to customize the compiler opton.
14 #
15 #EXTRA_ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION} "
16 #
17 # Unfortunately in do_extra_ipl_opt() it use d.setVar() instead of d.appendVar()
18 # to setup EXTRA_ATFW_OPT variable which makes it impossible to customize it properly
19 # by others... Override it.
20
21 #
22 do_ipl_opt_compile_refhw () {
23     oe_runmake distclean
24     oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${EXTRA_ATFW_OPT} ${ATFW_OPT_LOSSY} ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}
25 }
26