bf2874f1047707d9f294c72fcd0980ede744c995
[AGL/meta-agl-refhw.git] / meta-agl-refhw-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRC_URI += "file://0001-Boot-Normal-World-in-EL2.patch"
4
5 # It is believed the eMMC configuration below makes the result AGL
6 # reference hardware specific, mark it as such to try to prevent
7 # unintended usage on other boards.
8 COMPATIBLE_MACHINE = "agl-refhw-h3"
9
10 # There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
11 # u-boot have to be stored into eMMC by using serial donwload.
12 EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
13
14 DDR_8G_OPTION= "RCAR_DRAM_LPDDR4_MEMCONF=1"
15
16 ATFW_OPT_append_agl-refhw-h3 = " ${EMMC_BOOT_OPTION}"
17
18 # In arm-trusted-firmware-control.inc, a "extra_ipl_opt" task is appended to
19 # create firmware for 4x2g or 2x2g variation. it is supposed to use
20 # EXTRA_ATFW_OPT to customize the compiler opton.
21 #
22 #EXTRA_ATFW_OPT_append_agl-refhw-h3 = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
23 #
24 # Unfortunately in do_extra_ipl_opt() it use d.setVar() instead of d.appendVar()
25 # to setup EXTRA_ATFW_OPT variable which makes it impossible to customize it properly
26 # by others... Override it.
27
28 #
29 do_ipl_opt_compile_agl-refhw-h3 () {
30     oe_runmake distclean
31     oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${EXTRA_ATFW_OPT} ${ATFW_OPT_LOSSY} ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}
32 }
33