85ebc29d6bd811dfa4cbc75c2ce1a2e89d0f6e9e
[AGL/meta-agl.git] / meta-agl-profile-graphical-qt5 / recipes-qt / qt5 / qtwayland_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 # QT_MODULE_BRANCH = "5.4"
4
5 # TODO:
6 #  These patches for IVI-SHELL are tempolary disabled because of issues. And new
7 #  patches are proposed.
8 #
9 #    file://0020-Add-IVI-Shell-protocol-file-version-patch-v6.patch \
10 #    file://0021-Implement-initial-IVI-Shell-support.patch \
11 #    file://0001-protocol-update-3rd-party-ivi-application-protocol.patch \
12 #    file://0002-qwaylandwindow-add-support-for-IVI-Surface-ID-proper.patch \
13 #
14 #  The xdg-shell merged into upstream, so we don't need these patch anymore.
15 #  But xdg-shell doesn't work well in current AGL Distro because of
16 #  mismatch of protocol versions between server(weston) and client(Qt Apps).
17 #
18 #    file://0016-xdg-shell-Add-xdg-shell-protocol-file-version-1.4.0.patch \
19 #    file://0017-xdg-shell-Add-minimize-feature-to-QWindow-using-wayl.patch \
20 #    file://0019-xdg-shell-upgrade-to-support-current-version-weston-.patch \
21 #
22
23 SRC_URI_append = "\
24     file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
25     "
26
27 AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
28 AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
29 QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
30
31 do_install_append_class-target() {
32         mkdir -p ${AFM_CONF_DIR}
33         echo "QT_WAYLAND_SHELL_INTEGRATION=${AGL_DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
34         echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
35 }