weston_8.0.%.bbappend: Remove unused patch
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 # NOTE:
4 #    file://0003-compositor-drm-introduce-drm_get_dmafd_from_view.patch
5 #    has been removed until someone more familiar with weston internals
6 #    and waltham can take a look and update it.
7 SRC_URI_append = "\
8     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
9     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
10     file://smack-weston \
11     "
12
13 EXTRA_OEMESON_append = " -Denable-user-start=true"
14
15 # Workaround for incorrect upstream definition
16 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
17 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
18
19 do_install_append() {
20     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
21         # Install SMACK rules
22         install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
23     fi
24 }
25
26 FILES_${PN} += "\
27     ${sysconfdir}/smack/accesses.d/* \
28 "