meta-agl-profile-graphical: backport weston drm tear-down fix
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 # NOTE:
4 #    file://0003-compositor-drm-introduce-drm_get_dmafd_from_view.patch
5 #    has been removed until someone more familiar with weston internals
6 #    and waltham can take a look and update it.
7 SRC_URI_append = "\
8     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
9     file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
10     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
11     file://0004-main-change-remoting-initialization-timing.patch \
12     file://0005-correctly-tear-down-drm-backend.patch \
13     file://smack-weston \
14     "
15
16 EXTRA_OEMESON_append = " -Denable-user-start=true"
17
18 # Workaround for incorrect upstream definition
19 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
20 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
21
22 do_install_append() {
23     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
24         # Install SMACK rules
25         install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
26     fi
27 }
28
29 FILES_${PN} += "\
30     ${sysconfdir}/smack/accesses.d/* \
31 "