weston_8.0.%.bbappend: Add weston_seat_* patch
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
5     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
6     file://0001-libweston-Migrate-weston_seat_init-release-to-public.patch \
7     file://smack-weston \
8     "
9
10 EXTRA_OEMESON_append = " -Denable-user-start=true"
11
12 # Workaround for incorrect upstream definition
13 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
14 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
15
16 do_install_append() {
17     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
18         # Install SMACK rules
19         install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
20     fi
21 }
22
23 FILES_${PN} += "\
24     ${sysconfdir}/smack/accesses.d/* \
25 "