weston_8.0.%.bbappend: Remove unused patch
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
5     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
6     file://smack-weston \
7     "
8
9 EXTRA_OEMESON_append = " -Denable-user-start=true"
10
11 # Workaround for incorrect upstream definition
12 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
13 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
14
15 do_install_append() {
16     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
17         # Install SMACK rules
18         install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
19     fi
20 }
21
22 FILES_${PN} += "\
23     ${sysconfdir}/smack/accesses.d/* \
24 "