meta-agl-profile-telematics: recipes-core: systemd: change canbus systemd match regex
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / wayland-ivi-extension_2.0.2.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "ff067a640451de46836200624ece7ac777977c30"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=2.0;protocol=http \
10         file://0001-Added-ivi-id-agent-to-CMake.patch \
11         file://0002-ivi-id-agent-added-ivi-id-agent.patch \
12         file://0003-ivi-controller-load-id-agent-module.patch \
13         file://0002-add-LayerManagerControl-error-status.patch \
14         file://0004-ivi-ilmcontrol-added-focus-notification.patch \
15 "
16 SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
17
18 S = "${WORKDIR}/git"
19
20 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
21
22 FILESEXTRAPATHS_prepend := ":${THISDIR}/wayland-ivi-extension:"
23
24 # workaround paralellism issue:
25 PARALLEL_MAKE = ""
26
27 inherit cmake
28
29 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
30
31 FILES_${PN} += "${libdir}/weston/*"
32 FILES_${PN} += "${datadir}/wayland-protocols/stable/ivi-application/*"
33
34 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
35
36 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"