weston: add weston-ready
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / wayland-ivi-extension_2.0.2.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "ff067a640451de46836200624ece7ac777977c30"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=2.0;protocol=http \
10            file://0001-simple-id-agent-for-2.0.2.patch \
11            file://0002-add-LayerManagerControl-error-status.patch \
12 "
13 SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
14
15 S = "${WORKDIR}/git"
16
17 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
18
19 FILESEXTRAPATHS_prepend := ":${THISDIR}/wayland-ivi-extension:"
20
21 # workaround paralellism issue:
22 PARALLEL_MAKE = ""
23
24 inherit cmake
25
26 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
27
28 FILES_${PN} += "${libdir}/weston/*"
29 FILES_${PN} += "${datadir}/wayland-protocols/stable/ivi-application/*"
30
31 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
32
33 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"