Remove legacy 'p' prefix in gerrit url
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / waltham-transmitter_git.bb
1 DESCRIPTION = "Waltham is a network IPC library designed to resemble Wayland both protocol and protocol-API wise"
2 HOMEPAGE = "https://github.com/waltham/waltham"
3
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
6
7 DEPENDS += "libdrm virtual/kernel wayland waltham weston gstreamer1.0 gstreamer gstreamer1.0-plugins-base gstreamer1.0-plugins-good"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/weston-ivi-plugins.git;protocol=https"
10 SRCREV = "b84f9487a32e5b94c93d34a984858a93d0cefc57"
11
12 S = "${WORKDIR}/git/"
13
14 WALTHAM_PIPELINE ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
15 WALTHAM_RECIEVER_IP ?= "192.168.1.2"
16 WALTHAM_RECEIVER_PORT ?= "3440"
17
18 inherit pkgconfig cmake
19
20 do_install_append () {
21    install -d ${D}/etc/xdg/weston/
22    install ${S}/${WALTHAM_PIPELINE} ${D}/etc/xdg/weston/pipeline.cfg
23
24    sed -i -e "s/YOUR_RECIEVER_IP/${WALTHAM_RECIEVER_IP}/g" ${D}/etc/xdg/weston/pipeline.cfg
25    sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/pipeline.cfg
26
27 }
28
29 FILES_${PN} += "/etc/xdg/weston/*.cfg"
30 FILES_${PN} += "${libdir}/*"