a34d143c2e3e71cde2b2de70a2a78b12db77cfe7
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / agl-compositor_git.bb
1 SUMMARY = "Reference Wayland compositor for AGL"
2 DESCRIPTION = "The AGL compositor is a reference Wayland server for Automotive \
3 Grade Linux, using libweston as a base to provide a graphical environment for \
4 the automotive environment."
5
6 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-compositor"
7 SECTION = "x11"
8 LICENSE = "MIT"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
10
11 DEPENDS = "wayland wayland-protocols wayland-native weston"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV = "39ea644837dd29cd47a579a9703b43458187f82b"
15
16 PV = "0.0.10+git${SRCPV}"
17 S = "${WORKDIR}/git"
18
19 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
20
21 inherit meson pkgconfig python3native
22
23 FILES_${PN} = " \
24                ${bindir}/agl-compositor \
25                ${datadir}/${PN}/protocols/agl-shell.xml \
26                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
27               "