meta-agl-profile-graphical-qt5: Update libqtappfw SRCREV
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / agl-desktop-config / agl-desktop-config_0.1.bb
1 SUMMARY = "AGL desktop config"
2
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6 SRC_URI += " \
7     file://user-weston-term.service \
8     file://user-weston-term.path \
9 "
10
11 do_install_append() {
12     install -d ${D}${systemd_user_unitdir}
13     install -m 0644 ${WORKDIR}/user-weston-term.service ${D}${systemd_user_unitdir}
14     install -m 0644 ${WORKDIR}/user-weston-term.path ${D}${systemd_user_unitdir}
15
16     install -d ${D}${systemd_user_unitdir}/default.target.wants
17     ln -sf ${systemd_user_unitdir}/user-weston-term.path ${D}${libdir}/systemd/user/default.target.wants
18 }
19
20 FILES_${PN} += "${systemd_user_unitdir}/*"
21 FILES_${PN} += "${systemd_user_unitdir}/default.target.wants/default.target.wants"