4be5ab1da6b80113e776b3dbb2f9351cc2b1740b
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-apis / agl-service-windowmanager / agl-service-windowmanager_git.bb
1 SUMMARY     = "Window Manager service binding for applications"
2 DESCRIPTION = "Window Manager is the service binding for controlling \
3                rendering rights. Applications request to render itself, \
4                then Window Manager checks the policy and notifies the \
5                layout to the respective applications \
6               "
7 HOMEPAGE    = "https://wiki.automotivelinux.org/windowmanager"
8 SECTION     = "graphics"
9 LICENSE     = "Apache-2.0"
10 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
11
12 DEPENDS = "af-binder json-c wayland wayland-ivi-extension"
13
14 inherit cmake aglwgt
15
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
17            file://weston-ready.conf \
18 "
19 SRCREV = "${AGL_APP_REVISION}"
20 PV = "1.0+git${SRCPV}"
21 S = "${WORKDIR}/git"
22
23 do_install_append() {
24     # Install systemd over-ride that adds a dependency on weston-ready
25     # to ensure that the windowmanager and its dependencies start after
26     # weston is actually initialized.
27     install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
28     install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
29 }
30
31 FILES_${PN} += "${systemd_system_unitdir}"
32
33 RDEPENDS_${PN} += "weston-ready"