packagegroup-agl-test: Install evtest.
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / packagegroups / packagegroup-agl-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-test \
10     packagegroup-agl-test-ltp \
11     packagegroup-ivi-common-test \
12     "
13
14 ALLOW_EMPTY_${PN} = "1"
15
16 RDEPENDS_${PN} += "\
17     bc \
18     dbench \
19     ebizzy \
20     evtest \
21     ffsb \
22     interbench \
23     iozone3 \
24     iperf3 \
25     ipv6connect \
26     linpack \
27     linus-stress \
28     lmbench \
29     nbench-byte \
30     rt-tests \
31     stress \
32     "
33 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
34 #    netperf
35
36 # FTBS, SPEC-316
37 #    himeno 
38 # FTBS, SPEC-1384
39 #    trinity
40
41 #    packagegroup-agl-test-ltp \
42 #    ltp \
43 #
44
45 # Packages for shell commands which are required by LTP
46 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
47 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
48 #   pgrep
49 RDEPENDS_packagegroup-agl-test-ltp += " \
50     initscripts-functions bind-utils binutils \
51     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
52     iptables logrotate net-tools sysstat tcpdump vsftpd \
53     "
54
55 RDEPENDS_packagegroup-ivi-common-test = " \
56     packagegroup-agl-test \
57     "