74d90f0df49423001558fb2c5be413839789f4bd
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / packagegroups / packagegroup-agl-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-test \
10     packagegroup-agl-test-ltp \
11     packagegroup-ivi-common-test \
12     "
13
14 ALLOW_EMPTY_${PN} = "1"
15
16 RDEPENDS_${PN} += "\
17     bc \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf3 \
24     ipv6connect \
25     linpack \
26     linus-stress \
27     lmbench \
28     nbench-byte \
29     rt-tests \
30     stress \
31     "
32 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
33 #    netperf
34
35 # FTBS, SPEC-316
36 #    himeno 
37 # FTBS, SPEC-1384
38 #    trinity
39
40 #    packagegroup-agl-test-ltp \
41 #    ltp \
42 #
43
44 # Packages for shell commands which are required by LTP
45 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
46 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
47 #   pgrep
48 RDEPENDS_packagegroup-agl-test-ltp += " \
49     initscripts-functions bind-utils binutils \
50     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
51     iptables logrotate net-tools sysstat tcpdump vsftpd \
52     "
53
54 RDEPENDS_packagegroup-ivi-common-test = " \
55     packagegroup-agl-test \
56     "