48301078e76a92ec481893e90af98731229c90d7
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / packagegroups / packagegroup-agl-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-test \
10     packagegroup-agl-test-ltp \
11     packagegroup-ivi-common-test \
12     "
13
14 ALLOW_EMPTY_${PN} = "1"
15
16 RDEPENDS_${PN} += "\
17     bc \
18     dbench \
19     ebizzy \
20     evtest \
21     ffsb \
22     glmark2 \
23     interbench \
24     iozone3 \
25     iperf3 \
26     ipv6connect \
27     linpack \
28     linus-stress \
29     lmbench \
30     nbench-byte \
31     nmap \
32     rt-tests \
33     stress \
34     "
35 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
36 #    netperf
37
38 # FTBS, SPEC-316
39 #    himeno 
40 # FTBS, SPEC-1384
41 #    trinity
42
43 #    packagegroup-agl-test-ltp \
44 #    ltp \
45 #
46
47 # Packages for shell commands which are required by LTP
48 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
49 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
50 #   pgrep
51 RDEPENDS_packagegroup-agl-test-ltp += " \
52     initscripts-functions bind-utils binutils \
53     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
54     iptables logrotate net-tools sysstat tcpdump vsftpd \
55     "
56
57 RDEPENDS_packagegroup-ivi-common-test = " \
58     packagegroup-agl-test \
59     "