412d43875481c5f4fb2c84323b6c4cd88848033b
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / packagegroups / packagegroup-agl-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-test \
10     packagegroup-agl-test-ltp \
11     packagegroup-ivi-common-test \
12     "
13
14 ALLOW_EMPTY_${PN} = "1"
15
16 RDEPENDS_${PN} += "\
17     bc \
18     dbench \
19     ebizzy \
20     evtest \
21     ffsb \
22     interbench \
23     iozone3 \
24     iperf3 \
25     ipv6connect \
26     linpack \
27     linus-stress \
28     lmbench \
29     nbench-byte \
30     nmap \
31     rt-tests \
32     stress \
33     "
34 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
35 #    netperf
36
37 # FTBS, SPEC-316
38 #    himeno 
39 # FTBS, SPEC-1384
40 #    trinity
41
42 #    packagegroup-agl-test-ltp \
43 #    ltp \
44 #
45
46 # Packages for shell commands which are required by LTP
47 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
48 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
49 #   pgrep
50 RDEPENDS_packagegroup-agl-test-ltp += " \
51     initscripts-functions bind-utils binutils \
52     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
53     iptables logrotate net-tools sysstat tcpdump vsftpd \
54     "
55
56 RDEPENDS_packagegroup-ivi-common-test = " \
57     packagegroup-agl-test \
58     "