84bed0ff6ed198be619814c4b20cd92015b66a89
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / linpack / linpack.bb
1 SUMMARY = "Linpack benchmark"
2 LICENSE = "BSD"
3 LIC_FILES_CHKSUM = "file://${S}/${PN}/linpack.c;md5=076f1fd8d313056103f98d4253862eae"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
6 SRCREV = "920cae73a918d1f516113b0ae967be3ecaba86ef"
7
8 DEPENDS += "rsync-native"
9
10 inherit autotools
11
12 S = "${WORKDIR}/git"
13
14 # configure script is not delivered, only a makefile.
15 do_configure() {
16     mkdir -p ${B}
17     rsync -a ${S}/${PN}/* ${B}
18 }
19
20 do_install() {
21     install -d ${D}${bindir}
22     install -m 0755 ${B}/linpack ${D}${bindir}
23 }