Merge "[RCAR] Update Rcar gen3 BSP to 3.6"
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / iperf / iperf_2.0.9.bb
1 DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
2 HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
3 SECTION = "console/network"
4 LICENSE = "BSD-2-Clause"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
6
7 SRC_URI = " https://iperf.fr/download/source/${BP}-source.tar.gz \
8           "
9
10 SRC_URI[md5sum] = "1bb3a1d98b1973aee6e8f171933c0f61"
11 SRC_URI[sha256sum] = "a5350777b191e910334d3a107b5e5219b72ffa393da4186da1e0a4552aeeded6"
12
13 S = "${WORKDIR}/${BP}"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF = "--exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
18
19 PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
20 PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"