Bump afb-test revision
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / afb-test / afb-test_git.bb
1 SUMMARY = "Binding embedding test framework to test others binding"
2 DESCRIPTION = "This make testing binding running with Application Framework binder \
3 easier by simply test verb return as well as event reception."
4 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/app-afb-test"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7 SECTION = "apps"
8
9 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH} \
10            file://run-ptest \
11           "
12 SRCREV = "7b69512a0d4ed9b994ec02ed7f9ae004e9533d1f"
13
14 DEPENDS += "lua"
15 RDEPENDS_${PN} += "lua bash"
16 RDEPENDS_${PN}-ptest += "af-binder"
17
18 PV = "${AGLVERSION}"
19 S  = "${WORKDIR}/git"
20
21 inherit cmake aglwgt pkgconfig ptest
22
23 do_install_append() {
24        install -d ${D}${bindir}
25        install -m 775 ${S}/afm-test.target.sh ${D}${bindir}/afm-test
26 }
27