libmicrohttpd: Upgrade to version 0.9.63
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-support / libmicrohttpd / libmicrohttpd_0.9.63.bb
1 DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2 HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3 LICENSE = "LGPL-2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5 SECTION = "net"
6 DEPENDS = "file"
7
8 SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9 SRC_URI[md5sum] = "1c10de049608fca46941cbc790e3ab00"
10 SRC_URI[sha256sum] = "37c36f1be177f0e37ef181a645cd3baac1000bd322a01c2eff70f3cc8c91749c"
11
12 inherit autotools lib_package pkgconfig gettext
13
14 CFLAGS += "-pthread -D_REENTRANT"
15
16 EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
17
18 PACKAGECONFIG ?= "curl https"
19 PACKAGECONFIG_append_class-target = "\
20         ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
21 "
22 PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
23 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
24 PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
25
26 do_compile_append() {
27     sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
28 }