6ef68ca90a817018425f453fed925a3975dc9ba8
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-platform / packagegroups / packagegroup-agl-core-connectivity.bb
1 DESCRIPTION = "The minimal set of packages for Connectivity Subsystem"
2 LICENSE = "MIT"
3
4 inherit packagegroup
5
6 PACKAGES = "\
7     packagegroup-agl-core-connectivity \
8     "
9
10 ALLOW_EMPTY_${PN} = "1"
11
12 RDEPENDS_${PN} += "\
13     bluez5-obex \
14     dhcp-server \
15     ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-tests connman-tools connman-ncurses','',d)} \
16     ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
17     neard \
18     neardal-tools \
19     rtl-sdr \
20     "