agl-image-minimal-crosssdk: add afb-helpers & appcontroller libs
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-platform / images / agl-image-minimal-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for core profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-image-minimal.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES_append = " dev-pkgs"
12 IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
13
14 # required dependencies for app and test builds
15 # also in the minimal image (SPEC-1678)
16 TOOLCHAIN_HOST_TASK += " \
17     nativesdk-lua \
18     "
19
20 # required dependencies for app and test builds
21 # also in the minimal image (SPEC-1678)
22 TOOLCHAIN_TARGET_TASK += " \
23     lua-dev \
24     lua-staticdev \
25     libafb-helpers-staticdev \
26     libappcontroller-staticdev \
27     "
28
29 inherit populate_sdk
30
31 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
32 # Both exec "createrepo" on the same directory, and so one of them
33 # can failed (randomly).
34 addtask do_populate_sdk after do_rootfs
35