Upgrade to thud
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-kernel / most / most.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 def prep_version (d) :
4         KV = d.getVar('KERNEL_VERSION', True)
5         if not KV :
6                 return "4.12"
7         else:
8                 return KV
9
10 ORIG_KERN_VER = "${@prep_version(d)}"
11
12 VANILLA_KERNEL_VERSION = "${@str(ORIG_KERN_VER.split("-")[0].split(".")[0]+ORIG_KERN_VER.split("-")[0].split(".")[1])}"
13
14 APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
15 APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
16
17 SRC_URI_append = " \
18             file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
19             file://0002-src-most-add-auto-conf-feature.patch \
20             file://0003-core-remove-kernel-log-for-MBO-status.patch \
21             file://0004-most-video-set-device_caps.patch \
22             file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
23             file://0006-dim2-fix-startup-sequence.patch \
24             file://0007-dim2-use-device-tree.patch \
25             file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
26             file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
27             file://0010-backport-usb-setup-timer.patch \
28             file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
29            "
30 # Make sure we can expose KERNEL_VERSION ...
31 do_patch[depends] += "virtual/kernel:do_populate_sysroot"