Add afb-helpers & app-controller library recipes
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-devtools / libafb-helpers / libafb-helpers_git.bb
1 SUMMARY = "AFB helpers library"
2 DESCRIPTION = "AFB helpers library to ease JSON object manipulation and binding interaction"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libafb-helpers;protocol=https;branch=${AGL_BRANCH}"
8 SRCREV = "9cdebd57cf048c1c9ba89943f6ec2f9012bad6fc"
9
10 PV = "${AGLVERSION}"
11 S  = "${WORKDIR}/git"
12
13 DEPENDS_append = " af-binder qtwebsockets"
14 RDEPENDS_${PN}_append = " af-binder"
15
16 inherit cmake_qt5
17
18 ALLOW_EMPTY_${PN} = "1"