Introduce meta-agl-profile-core and meta-agl-profile-graphics
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-core / systemd / systemd_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 SRC_URI += "\
4     file://e2fsck.conf \
5     ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
6 "
7
8 # enable networkd/resolved support
9 PACKAGECONFIG_append_pn-systemd = " \
10    ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','networkd resolved','',d)} \
11 "
12
13 do_install_append() {
14     # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
15     install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
16
17     if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
18        # Install DHCP configuration for Ethernet adapters
19        install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
20     fi
21 }
22
23 FILES_${PN} += "${sysconfdir}/e2fsck.conf "
24
25 # SPEC-737: connmand also has a NTP client which races with systemd-timesyncd
26 PACKAGECONFIG_remove = "timesyncd"