recipes-connectivity: bluez5: add dbus-org.bluez.obex.service symlink
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-connectivity / bluez5 / bluez5_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
2 SRC_URI_append = " file://bluetooth.conf"
3
4 APPLY_v522 = "${@str('no' if '${PV}' != '5.22' else 'yes')}"
5
6 SRC_URI_append = "\
7     file://0001_fix_compile_issue_when_using_in_c++.patch;apply=${APPLY_v522} \
8 "
9
10
11 do_install_append() {
12     install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
13
14     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
15         mkdir -p ${D}/etc/systemd/user
16         ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
17     fi
18 }